vs 错误:

1、首先查看一下自己的网络

默认的Centos6.5 glibc版本最高为2.12,
而在进行Nodejs开发时项目所依赖的包往往需要更高版本的glibc库支持,
因此在不升级系统的前提下, 需要主动更新系统glibc库.
一般遇到错误libc.so.6: version GLIBC_2.14 not found时表示需要对glibc进行升级了.

    error LNK1104: 无法打开文件“libzmq.lib”

  ifconfig

 

解决方法:  

  我查看之后发现。。。。没有eth0

解决方案可参照下面链接

    你自己新建项目后,需要操作
项目》属性》链接器》常规》附加库目录》,然后把 libzmq.lib
库文件所在的目录添加进去。

  ok,现在去 /etc/sysconfig/network-scripts
目录中查看是否有  ifcfg-et0  文件,

 1
 

 

    1)有文件,可能是网卡没开

 

      nano ifcfg-eth0
更改: 图片 1

场景需求

默认的Centos6.5 glibc版本最高为2.12,
而在进行Nodejs开发时项目所依赖的包往往需要更高版本的glibc库支持,
因此在不升级系统的前提下, 需要主动更新系统glibc库.
一般遇到错误libc.so.6: version GLIBC_2.14 not found时表示需要对glibc进行升级了.

发表评论

电子邮件地址不会被公开。 必填项已用*标注